Difference between revisions of "LStore FAQ"

From ReddNet
Jump to navigation Jump to search
 
Line 1: Line 1:
***Question1: I am getting AllocateHardByte Failure on the IBP depots while uploading. What should I do? The error may look similar to :
+
*Question1: I am getting AllocateHardByte Failure on the IBP depots while uploading. What should I do? The error may look similar to :
 
         edu.utk.cs.loci.ibp.IBPException: Allocation failed
 
         edu.utk.cs.loci.ibp.IBPException: Allocation failed
 
         at edu.utk.cs.loci.ibp.ProtocolService.allocate(ProtocolService.java:114)
 
         at edu.utk.cs.loci.ibp.ProtocolService.allocate(ProtocolService.java:114)
Line 11: Line 11:
  
  
Answer: In the past we have seen this problem occur due to a mis-configuration of the IBP depot itself. Usually if the depot is mounted on a directory that does not exist it will give allocation failures. For example: if you have the ibp depot set up (in the ibp.cfg file) to be mounted on /foo. If /foo does not exist...you will see this kind of a failure. The fix is easy. Just match the directory structure.
+
*Answer: In the past we have seen this problem occur due to a mis-configuration of the IBP depot itself. Usually if the depot is mounted on a directory that does not exist it will give allocation failures. For example: if you have the ibp depot set up (in the ibp.cfg file) to be mounted on /foo. If /foo does not exist...you will see this kind of a failure. The fix is easy. Just match the directory structure.

Latest revision as of 08:55, 6 June 2006

  • Question1: I am getting AllocateHardByte Failure on the IBP depots while uploading. What should I do? The error may look similar to :
       edu.utk.cs.loci.ibp.IBPException: Allocation failed
       at edu.utk.cs.loci.ibp.ProtocolService.allocate(ProtocolService.java:114)
       at edu.utk.cs.loci.ibp.ProtocolService.allocateHardByteArray(ProtocolService.java:127)
       at edu.utk.cs.loci.ibp.Depot.allocateHardByteArray(Depot.java:109)
       at edu.utk.cs.loci.exnode.WriteJob.execute(WriteJob.java:88)
       at edu.utk.cs.loci.exnode.WriteThread.run(WriteThread.java:26)
       edu.utk.cs.loci.ibp.IBPException: Allocation failed
       at edu.utk.cs.loci.ibp.ProtocolService.allocate(ProtocolService.java:114)
       at edu.utk.cs.loci.ibp.ProtocolService.allocateHardByteArray(ProtocolService.java:127)


  • Answer: In the past we have seen this problem occur due to a mis-configuration of the IBP depot itself. Usually if the depot is mounted on a directory that does not exist it will give allocation failures. For example: if you have the ibp depot set up (in the ibp.cfg file) to be mounted on /foo. If /foo does not exist...you will see this kind of a failure. The fix is easy. Just match the directory structure.